How to get the connection information when migrating Navicat to new computer?

From Navicat Wiki
Jump to: navigation, search

Apply OS : Windows, Mac, Linux

Apply Navicat Product: All

Apply Navicat Version No. : Version 8.x or above


Windows

All the connection settings are stored in registry. To view the registry record, in Windows, Choose Start -> Run, then type "regedit".

Version File
MySQL HKEY_CURRENT_USER/Software/PremiumSoft/Navicat
PGSQL HKEY_CURRENT_USER/Software/PremiumSoft/NavicatPG
Oracle HKEY_CURRENT_USER/Software/PremiumSoft/NavicatOra
SQLite HKEY_CURRENT_USER/Software/PremiumSoft/NavicatSQLite
SQL Server HKEY_CURRENT_USER/Software/PremiumSoft/NavicatMSSQL
MariaDB HKEY_CURRENT_USER/Software/PremiumSoft/NavicatMARIADB
Premium HKEY_CURRENT_USER/Software/PremiumSoft/NavicatPremium

HKEY_CURRENT_USER/Software/PremiumSoft/Navicat
HKEY_CURRENT_USER/Software/PremiumSoft/NavicatOracle
HKEY_CURRENT_USER/Software/PremiumSoft/NavicatPGSQL
HKEY_CURRENT_USER/Software/PremiumSoft/NavicatSQLite
HKEY_CURRENT_USER/Software/PremiumSoft/NavicatMSSQL
HKEY_CURRENT_USER/Software/PremiumSoft/NavicatMARIADB


Navicat Version 8

  1. Choose File -> Export Registry File. The exported file (.reg) contains all your connection settings.
  2. Backup the exported file (.reg).
  3. Uninstall Navicat from the existing computer.
  4. Re-install Navicat in the new computer.
  5. Run the exported file (.reg) in the new computer

Navicat Version 9 or above

  1. In Navicat, choose File -> Export Connections. The exported file (.ncx) contains all your connection settings.
  2. Backup the exported file (.ncx).
  3. Uninstall Navicat from the existing computer.**
  4. Re-install Navicat in the new computer.
  5. Open Navicat and choose File -> Import Connections in the new computer.


** If you are using version 11 or above, please deactivate the registration key before uninstall Navicat.


When a new connection being established, Navicat will create a subfolder (with name in line with respective database) under the Settings Save Path. All backup (.psc, .psb), reports (.rtm), queries (.sql), import/export profile etc are stored within this subfolder. To look for the path, right-click the connection and choose Connection Properties/Edit Connection > Advanced > Settings Save Path/Settings Location.


In addition, all the saved profiles (e.g batch job profile) are stored under "profiles" folder. To look for the path, select Tools > Options, under Miscellaneous > Profiles Save Path/Profiles Location.


Mac

All the connection settings are saved in the Property List file:

Navicat Version 8 and 9

Version File
MySQL ~/Library/Preferences/com.prect.Navicat.plist
PGSQL ~/Library/Preferences/com.prect.NavicatPG.plist
Oracle ~/Library/Preferences/com.prect.NavicatORA.plist
SQLite ~/Library/Preferences/com.prect.NavicatSQLite.plist
SQL Server ~/Library/Preferences/com.prect.NavicatMSSQL.plist
Premium ~/Library/Preferences/com.prect.NavicatPremium.plist

~/Library/Preferences/com.prect.Navicat.plist
~/Library/Preferences/com.prect.NavicatORA.plist
~/Library/Preferences/com.prect.NavicatPG.plist
~/Library/Preferences/com.prect.NavicatSQLite.plist
~/Library/Preferences/com.prect.NavicatMSSQL.plist

Navicat Version 10 or above

~/Library/Application Support/PremiumSoft CyberTech/preference.plist


Migration Steps:

Navicat Vesion 8

  1. Backup the Property List files.
  2. Uninstall Navicat from the existing computer.
  3. Re-install Navicat in the new computer.
  4. Place the Property List files in the new computer.

Navicat Version 9 or above

  1. In Navicat, control-click anywhere in the navigation pane and choose Export Connections. The exported file (.ncx) contains all your connection settings (without passwords).
  2. Backup the exported file (.ncx).
  3. Uninstall Navicat from the existing computer.**
  4. Re-install Navicat in the new computer.
  5. Control-click anywhere in the navigation pane and choose Import Connections in the new computer.


** If you are using version 11 or above, please deactivate the registration key before uninstall Navicat.


When a new connection being established, Navicat will create a subfolder (with name in line with respective database) under the Settings Save Path. All backup (.pmb), queries (.sql) etc are stored within this subfolder. To look for the path, control-click the connection and choose Connection Properties/Edit Connection > Advanced > Settings Save Path/Settings Location.

Linux

All your connection settings are stored in a user.reg file. To view the registry record, in Linux (login as root for example), open /root/.navicat/user.reg where .navicat is a hidden folder.


Navicat Version 8

  1. Backup the user.reg file.
  2. Uninstall Navicat from the existing computer.
  3. Re-install Navicat in the new computer.
  4. Place the user.reg file in the new computer.

Navicat Version 9 or above

  1. In Navicat, choose File -> Export Connections. The exported file (.ncx) contains all your connection settings.
  2. Backup the exported file (.ncx).
  3. Uninstall Navicat from the existing computer.**
  4. Re-install Navicat in the new computer.
  5. Open Navicat and choose File -> Import Connections in the new computer.


** If you are using version 11 or above, please deactivate the registration key before uninstall Navicat.


When a new connection being established, Navicat will create a subfolder (with name in line with respective database) under the Settings Save Path. All backup (.psc, .psb), queries (.sql), import/export profile etc are stored within this subfolder. To look for the path, right-click the connection and choose Connection Properties/Edit Connection > Advanced > Settings Save Path/Settings Location.


In addition, all the saved profiles (e.g batch job profile) are stored under "profiles" folder. To look for the path, select Tools > Options, under Miscellaneous > Profiles Save Path/Profiles Location.